Instalando Gimp 2.8 en debian testing


Comenzamos por instalar las dependencias para la instalación / compilación de Gimp 2.8 para ello digitamos en una terminal de root:

aptitude install intltool libpng12-dev libglib2.0-dev libatk1.0-dev libpango1.0-dev libfontconfig1-dev libcairo2-dev libgtk2.0-dev libtiff4-dev python-gtk2-dev libatk1.0-dev librsvg2-bin libwebkit-dev librsvg2-2.0-cil-dev libjasper-dev liblcms-dev libexif-dev libwmf-dev

En nuestro caso, como usamos Debian 7.0 Wheezy o testing tambien instalamos:

aptitude install python2.7-dev

Ahora, lo primero a compilar son babl y gegl

wget ftp://ftp.gtk.org/pub/babl/0.1/babl-0.1.10.tar.bz2
tar -xvf babl-0.1.10.tar.bz2
cd babl-0.1.10/
./configure
make
su -c “make install”
wget ftp://ftp.gimp.org/pub/gegl/0.2/gegl-0.2.0.tar.bz2
tar -xvf gegl-0.2.0.tar.bz2
cd gegl-0.2.0/
./configure
make
su -c “make install”

Si tenemos instalado Gimp 2.6 debemos eliminarlo:

aptitude purge libgimp2.0 gimp gimp-help-en gimp-help-common gimp-data libgimp2.0

Ahora sí viene la instalación real del Gimp 2.8

wget ftp://ftp.gimp.org/pub/gimp/v2.8/gimp-2.8.0.tar.bz2
tar -xvf gimp-2.8.0.tar.bz2
cd gimp-2.8.0
./configure
make
su -c “make install”

FUENTE:http://www.lffl.org/2012/05/installare-gimp-28-su-debian-squeeze-e.html

NOTA: si al finalizar el trabajo les dice algo que la versión de BABL es antigua, bajaros los deb’s de ESTA PAGINA y luego los instalais con el acostumbrado dpkg

NOTA2: Listo. Debe funcionar, aunque si no inicia Gimp mediante el icono en el menú, podemos solucionarlo de esta forma:

Añadimos en nuestro fichero ~/.bashrc las siguientes líneas:

LD_LIBRARY_PATH=/usr/local/lib
env LD_LIBRARY_PATH=”/usr/local/lib” gimp
export LD_LIBRARY_PATH

Edidción cortesía de deblinux

Anuncios